Drive failure in France
Incident Report for Vortex Cloud Gaming
Resolved
This incident has been resolved.
Posted 13 days ago. Dec 02, 2018 - 23:29 UTC
Identified
We are rebuilding game library on one machine.
Posted 13 days ago. Dec 02, 2018 - 20:19 UTC
This incident affected: Servers status: Europe.